グローバルリソースで JDBC Proxy Server を指定した処理を実行した際に下記のエラーが発生しました

Avatar
dstn

Question

グローバルリソースで JDBC Proxy Server を指定した処理を実行した際に下記のエラーが発生しました。
SQLRemoteException: サーバ側との通信中にエラーが発生しました。

原因と対応方法を教えてください。

Answer

■原因

ご質問のエラーは、DataSpiderServer が、JDBC Proxy Server への
接続に失敗した場合に発生します。

過去事例では、以下のような原因で発生していました。

(1) JDBC Proxy Server への接続障害
  JDBC Proxy Server が停止していた、または、
  JDBC Proxy Server の設定情報で通信ができなかった。

(2) DataSpiderServer の再起動の未実施
  JDBC Proxy Server だけを再起動し、DataSpiderServer を
  再起動していなかった。
  この場合、DataSpiderServer が保持している接続情報が
  古いままとなり、エラーになることがあります。

(3) モジュールの不整合 
  DataSpiderServer と JDBC Proxy Server のバージョンに
  不整合が発生していた。
  この場合、モジュールの不整合によりエラーになります。

■対処方法

(1) JDBC Proxy Server の稼働状況やネットワーク設定の確認
 
事象発生時に JDBC Proxy Server か稼働していたことをご確認いただき
 停止していた場合には、起動してください。

 また、グローバルリソースで設定している「Proxyサーバ」、「Proxyポート番号」の値を
 使用して、DataSpiderServer をインストールしたサーバから、
 JDBC Proxy Server をインストールしたサーバにアクセス可能かご確認ください。

 接続できない場合には、設定内容や、ネットワーク環境の設定を変更してください。
 ※アクセス可能かを確認する手段としては、telnet などのツールがあります。
 ※詳細に関しては「参考情報」をご確認ください。

 なお、現状の JDBC Proxy Server の設定では NIC を指定する方法がないため、
 複数の NIC が設定されている場合には、1つの NIC のみを有効にするか、 
 IPアドレスがひとつだけ設定されているサーバに JDBC Proxy Server を
 インストールしてください。

(2) DataSpiderServer の再起動
 JDBC Proxy Server を再起動された場合、その後で、DataSpiderServer を
 再起動しているか確認してください。

 再起動されていない場合や再起動しているか不明な場合には、
 DataSpiderServer を再起動して事象が解消するか確認してください。

(3) モジュールのバージョンの一致
 DataSpiderServer と JDBC Proxy Server を同じバージョンの
 モジュールでインストールされていたか、ご確認ください。
 また、DataSpiderServer にパッチやサービスパックを適用されていて、
 そのパッチやサービスパックがJDBC Proxy Server のモジュールを
 含む場合は、JDBC Proxy Server にもパッチまたはサービスパックを
 適用しているかご確認ください。

 経緯が確認できない場合には、現在の DataSpiderServer のバージョンに
 合わせて JDBC Proxy Server を再インストールしていただくか、
 JDBC Proxy Server 用のパッチまたはサービスパックを再度適用してください。

上記にてエラーが解消されない場合は、「調査に必要な情報」を
取得していただき、サポートセンターまでお問い合わせをお願いいたします。

■調査に必要な情報
1.事象発生時刻
 事象が発生した時刻をご確認ください。

 また、その前後で変更された設定や実施された作業についても
 ご確認をお願いします。

2. 発生頻度や回避策の有無
 運用への影響を確認するために、事象の発生頻度(毎日、毎月、など)や
 回避策の有無(サービスの「回復」で再起動している、など)について
 ご確認をお願いします。

3.ログファイル
 事象が発生している DataSpiderServer の状態を確認させて
 いただきたいため、下記のログをご送付ください。
 $DATASPIDER_HOME/server/logs/server.log
 $DATASPIDER_HOME/server/logs/server.log.N (N:整数)
 $DATASPIDER_HOME/server/logs/server.error.log
 $DATASPIDER_HOME/server/logs/${実行日付}/exec.log

 また、該当時間帯に実行していた下記のログをご送付ください。
 $DATASPIDER_HOME/server/logs/${実行日付}/execution/${実行ID}.xml

4.JDBC Proxy Server のログ
 事象発生時の下記のログをご送付ください。
 $JDBCPROXY_HOME/logs/jdbcproxy.log

 また、事象発生時のタイムスタンプで出力されている
 下記のログがあれば、こちらもご送付ください。
 $JDBCPROXY_HOME/logs/hs_err_pidNNNN.log  (NNNN:整数)

5.OS 側のログ
 事象発生時の OS のイベントログなどに、JDBC Proxy Server に関する
 出力がなかったかどうかご確認ください。

 出力されている場合には、そちらをテキストファイルに
 コピーしたものをご送付ください。
 

参考情報

・telnet の使用方法
 以下のコマンドを実行することで、指定したポート番号で、指定したホストに
 アクセスできるか確認することができます。

telnet <ホスト名> <ポート番号>

 正常に通信できない場合、Connection refused などの通信エラーが発生します。
 正常に通信できる場合は、画面には何も表示されません。
 この場合、Ctrl+[ 押下にて telnet を終了してください。

 なお、OS のインストール直後には Telnet はインストールされておらず、
 別途インストールする必要があります。詳細は以下の公開情報をご参照ください。

・Telnet クライアントの概要(外部サイト)
 https://technet.microsoft.com/ja-jp/library/cc731442(v=ws.11).aspx

※Telnet はマイクロソフト社のツールとなりますので、使用方法の詳細でご不明点が
  ある場合には、開発元のマイクロソフト社までご確認をお願いいたします。
 



[注意事項]
  • このFAQの内容は2017年3月時点のものです。内容は予告なく変更されることがありますので、ご注意ください。
  • 一部にDataSpider Servistaサポートサイトへのリンクを含むことがあります。サポートサイトにアクセスするには、DataSpiderのサポート契約が必要です。


ID:Q276

コメント

記事コメントは受け付けていません。

Powered by Zendesk